GitHub Advisoryadvisory · npm
GHSA-qw96-mm2g-c8m7 Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page
MEDIUM
Official page ↗
- Aliases
- CVE-2018-18282
- Ecosystem
- npm
- Packages
- next
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm next: >= 7.0.0, < 7.0.2 → fixed in 7.0.2
Description
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
Related
Alias · CVE (1)
- CVE-2018-18282 Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness