GitHub Advisoryadvisory · Maven
GHSA-qwfv-5jwj-582h Opencast RCE Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-1000217
- Ecosystem
- Maven
- Packages
- org.opencastproject:base
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2023-07-26
Affected packages
• Maven org.opencastproject:base: < 2.3.3 → fixed in 2.3.3
Description
Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting in arbitrary code execution, fixed in 2.3.3 and 3.0.
Related
Alias · CVE (1)
- CVE-2017-1000217 Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting… vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000217 advisory
- https://github.com/opencast/opencast/commit/2d42e42f3cfcff3a775a2538f735fca8542ce1fc web
- https://github.com/opencast/opencast/commit/fba2f35df24ce2aeaff627200065cbade9b3a0cd web
- https://github.com/opencast/opencast package
- https://groups.google.com/a/opencast.org/forum/#!topic/security-notices/sCpt0pIPEFg web