GitHub Advisoryadvisory · Go
GHSA-qwrj-9hmp-gpxh FlyteAdmin Insufficient AccessToken Expiration Check
MEDIUM
Official page ↗
- Aliases
- CVE-2022-31145
- Ecosystem
- Go
- Packages
- github.com/flyteorg/flyteadmin
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-298, CWE-613
- Reviewed
- 2022-07-15
Affected packages
• Go github.com/flyteorg/flyteadmin: < 1.1.31 → fixed in 1.1.31
Description
Impact
Authenticated users using an external identity provider can continue to use Access Tokens and ID Tokens even after they expire.
Using flyteadmin as the OAuth2 Authorization Server is unaffected by this issue.
Patches
1.1.30
Workarounds
Rotating signing keys immediately will:
• Invalidate all open sessions,
• Force all users to attempt to obtain new tokens.
Continue to rotate keys until flyteadmin has been upgraded,
Hide flyteadmin deployment ingress url from the internet.
References
https://github.com/flyteorg/flyteadmin/pull/455
For more information
If you have any questions or comments about this advisory:
• Open an issue in flyte repo
• Email us at flyte
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2022-31145 FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. vulnerability
Weakness · CWE (1)
- CWE-298 Improper Validation of Certificate Expiration weakness
References
- https://github.com/flyteorg/flyteadmin/security/advisories/GHSA-qwrj-9hmp-gpxh web
- https://nvd.nist.gov/vuln/detail/CVE-2022-31145 advisory
- https://github.com/flyteorg/flyteadmin/pull/455 web
- https://github.com/flyteorg/flyteadmin/commit/a1ec282d02706e074bc4986fd0412e5da3b9d00a web
- https://github.com/flyteorg/flyteadmin package
- https://github.com/flyteorg/flyteadmin/releases/tag/v1.1.31 web
- https://pkg.go.dev/vuln/GO-2022-0519 web