GitHub Advisoryadvisory · Maven
GHSA-qwrx-45xf-jjf7 Elasticsearch vulnerable to stack overflow in the search API
MEDIUM
Official page ↗
- Aliases
- CVE-2023-31419
- Ecosystem
- Maven
- Packages
- org.elasticsearch:elasticsearch
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-121, CWE-787
- Reviewed
- 2023-10-30
Affected packages
• Maven org.elasticsearch:elasticsearch: >= 7.0.0, < 7.17.13 → fixed in 7.17.13
• Maven org.elasticsearch:elasticsearch: >= 8.0.0, < 8.9.1 → fixed in 8.9.1
Description
A flaw was discovered in Elasticsearch affecting the `_search` API that allowed a specially crafted query string to cause a stack overflow and ultimately a denial of service.
Related
Alias · CVE (1)
- CVE-2023-31419 A flaw was discovered in Elasticsearch, affecting the _search API that allowed a specially crafted query string to cause a Stack Overflow… vulnerability