GitHub Advisoryadvisory · PyPI
GHSA-qx2v-j445-g354 Improper Input Validation in Google TensorFlow
HIGH
Official page ↗
- Aliases
- CVE-2018-7577
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-gpu
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2019-04-30
Affected packages
• PyPI tensorflow: >= 1.1.0, < 1.7.1 → fixed in 1.7.1
• PyPI tensorflow-gpu: >= 1.1.0, < 1.7.1 → fixed in 1.7.1
Description
Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from other parts of process memory.
Related
Alias · CVE (1)
- CVE-2018-7577 Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-7577 advisory
- https://github.com/tensorflow/tensorflow/commit/dfa9921e6343727b05f42f8d4a918b19528ff994 web
- https://github.com/advisories/GHSA-qx2v-j445-g354 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-225.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-232.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-207.yaml web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md web