GitHub Advisoryadvisory · Packagist
GHSA-qx76-c53f-5c7q PHP League CommonMark vulnerable to Cross-Site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2018-20583
- Ecosystem
- Packagist
- Packages
- league/commonmark
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-09-12
Affected packages
• Packagist league/commonmark: >= 0.15.6, < 0.18.1 → fixed in 0.18.1
Description
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).
Related
Alias · CVE (1)
- CVE-2018-20583 Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-20583 advisory
- https://github.com/thephpleague/commonmark/issues/337 web
- https://commonmark.thephpleague.com/changelog web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/league/commonmark/CVE-2018-20583.yaml web
- https://github.com/thephpleague/commonmark package
- https://github.com/thephpleague/commonmark/releases/tag/0.18.1 web