GitHub Advisoryadvisory · PyPI
GHSA-qxh9-r8xw-7v99 OpenEXR invalid write
HIGH
Official page ↗
- Aliases
- CVE-2017-9111
- Ecosystem
- PyPI
- Packages
- OpenEXR
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-787
- Reviewed
- 2025-04-22
Affected packages
• PyPI OpenEXR: < 2.2.1 → fixed in 2.2.1
Description
In OpenEXR 2.2.0, an invalid write of size 8 in the storeSSE function in ImfOptimizedPixelReading.h could cause the application to crash or execute arbitrary code.
Related
Alias · CVE (1)
- CVE-2017-9111 In OpenEXR 2.2.0, an invalid write of size 8 in the storeSSE function in ImfOptimizedPixelReading.h could cause the application to crash or… vulnerability
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-9111 advisory
- https://github.com/openexr/openexr/issues/232 web
- https://github.com/openexr/openexr/pull/233 web
- https://github.com/AcademySoftwareFoundation/openexr package
- https://github.com/openexr/openexr/releases/tag/v2.2.1 web
- https://lists.debian.org/debian-lts-announce/2020/08/msg00056.html web
- https://usn.ubuntu.com/4148-1 web
- https://usn.ubuntu.com/4339-1 web
- https://www.debian.org/security/2020/dsa-4755 web
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00060.html web
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00000.html web
- http://www.openwall.com/lists/oss-security/2017/05/12/5 web