GitHub Advisoryadvisory · Go
GHSA-qxqc-27pr-wgc8 GoAuthentik vulnerable to Insufficient Authorization for several API endpoints
CRITICAL
Official page ↗
- Aliases
- CVE-2024-42490
- Ecosystem
- Go
- Packages
- goauthentik.io
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:H
- Weaknesses
- CWE-285, CWE-863
- Reviewed
- 2024-08-22
Affected packages
• Go goauthentik.io: >= 2024.6.0-rc1, < 2024.6.4 → fixed in 2024.6.4
• Go goauthentik.io: < 2024.4.4 → fixed in 2024.4.4
Description
Summary
Several API endpoints can be accessed by users without correct authentication/authorization.
The main API endpoints affected by this:
• `/api/v3/crypto/certificatekeypairs//view_certificate/`
• `/api/v3/crypto/certificatekeypairs//view_private_key/`
• `/api/v3/.../used_by/`
Note that all of the affected API endpoints require the knowledge of the ID of an object, which especially for certificates is not accessible to an unprivileged user. Additionally the IDs for most objects are UUIDv4, meaning they are not easily guessable/enumerable.
Patches
authentik 2024.4.4, 2024.6.4 and 2024.8.0 fix this issue.
Workarounds
Access to the API endpoints can be blocked at a Reverse-proxy/Load balancer level to prevent this issue from being exploited.
For more information
If you have any questions or comments about this advisory:
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2024-42490 authentik is an open-source Identity Provider. vulnerability
References
- https://github.com/goauthentik/authentik/security/advisories/GHSA-qxqc-27pr-wgc8 web
- https://nvd.nist.gov/vuln/detail/CVE-2024-42490 advisory
- https://github.com/goauthentik/authentik/commit/19318d4c00bb02c4ec3c4f8f15ac2e1dbe8d846c web
- https://github.com/goauthentik/authentik/commit/359b343f51524342a5ca03828e7c975a1d654b11 web
- https://github.com/goauthentik/authentik package