GitHub Advisoryadvisory · Go

GHSA-r236-5pc3-3qcp AWS Advanced Go Wrapper has Privilege Escalation in Aurora PostgreSQL instance

HIGH Published 2026-06-11 Modified 2026-06-11 Official page ↗
Aliases
CVE-2026-11401
Ecosystem
Go
Packages
github.com/aws/aws-advanced-go-wrapper/awssql/v2, github.com/aws/aws-advanced-go-wrapper/xray, github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager, github.com/aws/aws-advanced-go-wrapper/custom-endpoint, github.com/aws/aws-advanced-go-wrapper/federated-auth, github.com/aws/aws-advanced-go-wrapper/iam, github.com/aws/aws-advanced-go-wrapper/mysql-driver, github.com/aws/aws-advanced-go-wrapper/okta, github.com/aws/aws-advanced-go-wrapper/pgx-driver, github.com/aws/aws-advanced-go-wrapper/otlp, github.com/aws/aws-advanced-go-wrapper/auth-helpers
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-426
Reviewed
2026-06-11

Affected packages

• Go github.com/aws/aws-advanced-go-wrapper/awssql/v2: < 2.0.1 → fixed in 2.0.1 • Go github.com/aws/aws-advanced-go-wrapper/xray: < 1.07 → fixed in 1.07 • Go github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager: < 1.1.2 → fixed in 1.1.2 • Go github.com/aws/aws-advanced-go-wrapper/custom-endpoint: < 1.0.4 → fixed in 1.0.4 • Go github.com/aws/aws-advanced-go-wrapper/federated-auth: < 1.1.1 → fixed in 1.1.1 • Go github.com/aws/aws-advanced-go-wrapper/iam: < 1.1.1 → fixed in 1.1.1 • Go github.com/aws/aws-advanced-go-wrapper/mysql-driver: < 1.1.1 → fixed in 1.1.1 • Go github.com/aws/aws-advanced-go-wrapper/okta: < 1.1.1 → fixed in 1.1.1 • Go github.com/aws/aws-advanced-go-wrapper/pgx-driver: < 1.1.1 → fixed in 1.1.1 • Go github.com/aws/aws-advanced-go-wrapper/otlp: < 1.0.7 → fixed in 1.0.7 • Go github.com/aws/aws-advanced-go-wrapper/auth-helpers: < 1.1.1 → fixed in 1.1.1

Description

Aurora PostgreSQL is a fully managed relational database engine that's compatible with PostgreSQL. An issue in Aurora PostgreSQL using the AWS Go Wrapper waa identified, see CVE-2026-11401. Impact An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. Impacted versions: AWS Go Wrapper 2026-04-06 Patches This issue has been addressed in AWS Go Wrapper 2026-05-26. Maintainers recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. Workarounds Remove the public schema from the search path. References If there are any questions or comments about this advisory, contact [AWS/Amazon] Security via the vulnerability reporting page or directly via email to [email protected]. Please do not create a public GitHub issue.

Related

Alias · CVE (1)

  • CVE-2026-11401 An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced Go Wrapper for Amazon Aurora PostgreSQL will allow a remote… vulnerability

Weakness · CWE (1)

  • CWE-426 Untrusted Search Path weakness

References