GitHub Advisoryadvisory · PyPI

GHSA-r23q-823p-vmf7 MLflow Command Injection vulnerability

CRITICAL Published 2026-03-30 Modified 2026-04-01 Official page ↗
Aliases
CVE-2025-15379
Ecosystem
PyPI
Packages
mlflow
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2026-04-01

Affected packages

• PyPI mlflow: < 3.8.1 → fixed in 3.8.1

Description

A command injection vulnerability exists in MLflow's model serving container initialization code, specifically in the `_install_model_dependencies_to_env()` function. When deploying a model with `env_manager=LOCAL`, MLflow reads dependency specifications from the model artifact's `python_env.yaml` file and directly interpolates them into a shell command without sanitization. This allows an attacker to supply a malicious model artifact and achieve arbitrary command execution on systems that deploy the model. The vulnerability affects versions 3.8.0 and is fixed in version 3.8.1.

Related

Alias · CVE (1)

  • CVE-2025-15379 A command injection vulnerability exists in MLflow's model serving container initialization code, specifically in the… vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References