GitHub Advisoryadvisory · PyPI

GHSA-r2x6-cjg7-8r43 snowflake-connector-python vulnerable to insecure cache files permissions

MEDIUM Published 2025-01-29 Modified 2025-04-09 Official page ↗
Aliases
CVE-2025-24795
Ecosystem
PyPI
Packages
snowflake-connector-python
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-276
Reviewed
2025-01-29

Affected packages

• PyPI snowflake-connector-python: >= 2.3.7, < 3.13.1 → fixed in 3.13.1

Description

Issue Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. On Linux systems, when temporary credential caching is enabled, the Snowflake Connector for Python will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 2.3.7 through 3.13.0. Snowflake fixed the issue in version 3.13.1. Vulnerability Details On Linux, when either EXTERNALBROWSER or USERNAME_PASSWORD_MFA authentication methods are used with temporary credential caching enabled, the Snowflake Connector for Python will cache the temporary credentials in a local file. In the vulnerable versions of the Driver, this file is created with world-readable permissions. Solution Snowflake released version 3.13.1 of the Snowflake Connector for Python, which fixes this issue. We recommend users upgrade to version 3.13.1. Additional Information If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne. For more information, please see our Vulnerability Disclosure Policy.

Related

Alias · CVE (1)

  • CVE-2025-24795 The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all… vulnerability

Weakness · CWE (1)

  • CWE-276 Incorrect Default Permissions weakness

References