GitHub Advisoryadvisory · Packagist
GHSA-r355-75hw-r8jf Magento allows incorrect authorization
MEDIUM
Official page ↗
- Aliases
- CVE-2025-54265
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-10-20
Affected packages
• Packagist magento/community-edition: >= 2.4.9-alpha1, < 2.4.9-alpha3 → fixed in 2.4.9-alpha3
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-p3 → fixed in 2.4.8-p3
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p8 → fixed in 2.4.7-p8
• Packagist magento/community-edition: < 2.4.6-p13 → fixed in 2.4.6-p13
• Packagist magento/community-edition: 2.4.8 (no fix yet)
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Magento versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by an Incorrect Authorization vulnerability. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized read access. Exploitation of this issue does not require user interaction.
Related
Alias · CVE (1)
- CVE-2025-54265 Adobe Commerce versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by an Incorrect… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness