GitHub Advisoryadvisory · RubyGems
GHSA-r364-2pj4-pf7f ruby-saml vulnerable to XPath injection
CRITICAL
Official page ↗
- Aliases
- CVE-2015-20108
- Ecosystem
- RubyGems
- Packages
- ruby-saml
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
- Reviewed
- 2023-06-06
Affected packages
• RubyGems ruby-saml: < 1.0.0 → fixed in 1.0.0
Description
`xml_security.rb` in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.
Related
Alias · CVE (1)
- CVE-2015-20108 xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not… vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-20108 advisory
- https://github.com/SAML-Toolkits/ruby-saml/pull/225 web
- https://github.com/SAML-Toolkits/ruby-saml/commit/9853651b96b99653ea8627d757d46bfe62ab6448 web
- https://github.com/SAML-Toolkits/ruby-saml package
- https://github.com/SAML-Toolkits/ruby-saml/compare/v0.9.2...v1.0.0 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2015-20108.yml web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/OSVDB-124991.yml web
- https://security.netapp.com/advisory/ntap-20230703-0003 web
- https://security.snyk.io/vuln/SNYK-RUBY-RUBYSAML-20217 web