GitHub Advisoryadvisory · PyPI
GHSA-r3jc-vhf4-6v32 CKAN has Cross-site Scripting vector in the Datatables view plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2024-41675
- Ecosystem
- PyPI
- Packages
- ckan
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-08-21
Affected packages
• PyPI ckan: >= 2.7.0, < 2.10.5 → fixed in 2.10.5
Description
The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector.
Impact
Sites running CKAN >= 2.7.0 with the `datatables_view` plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data.
Patches
This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0
Workarounds
Prevent importing of tabular files to the DataStore via DataPusher, XLoader,etc, at least those published from untrusted sources.
Related
Alias · CVE (1)
- CVE-2024-41675 CKAN is an open-source data management system for powering data hubs and data portals. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/ckan/ckan/security/advisories/GHSA-r3jc-vhf4-6v32 web
- https://nvd.nist.gov/vuln/detail/CVE-2024-41675 advisory
- https://github.com/ckan/ckan/commit/9e89ce8220ab1445e0bd85a67994a51d9d3d2688 web
- https://github.com/ckan/ckan/commit/d7dfe8c427b1c63c75d788a609f3b7d7620a25a1 web
- https://github.com/ckan/ckan package