GitHub Advisoryadvisory · Packagist
GHSA-r487-9vv5-75gg Magento Improper Authorization leading to security feature bypass
HIGH
Official page ↗
- Aliases
- CVE-2025-43585
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
- Weaknesses
- CWE-285
- Reviewed
- 2025-10-22
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p6 → fixed in 2.4.7-p6
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p11 → fixed in 2.4.6-p11
• Packagist magento/community-edition: < 2.4.5-p13 → fixed in 2.4.5-p13
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.8 (no fix yet)
Description
Magento versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access leading to a limited impact to confidentiality and a high impact to integrity. Exploitation of this issue does not require user interaction.
Related
Alias · CVE (1)
- CVE-2025-43585 Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by an Improper Authorization… vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness