GitHub Advisoryadvisory · PyPI

GHSA-r48c-4vfj-h426 collective.dms.basecontent Cross-site Scripting vulnerability

MEDIUM Published 2022-12-14 Modified 2024-09-06 Official page ↗
Aliases
CVE-2022-4495
Ecosystem
PyPI
Packages
collective.dms.basecontent
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-12-16

Affected packages

• PyPI collective.dms.basecontent: < 1.7 → fixed in 1.7

Description

A vulnerability, which was classified as problematic, has been found in collective.dms.basecontent. This issue affects the function renderCell of the file src/collective/dms/basecontent/browser/column.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.7 or later will address this issue. The patch is at commit 6c4d616fcc771822a14ebae5e23f3f6d96d134bd. It is recommended to upgrade the affected component. The identifier VDB-215813 was assigned to this vulnerability.

Related

Alias · CVE (1)

  • CVE-2022-4495 A vulnerability, which was classified as problematic, has been found in collective.dms.basecontent up to 1.6. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References