GitHub Advisoryadvisory · npm
GHSA-r4m5-47cq-6qg8 Server-Side Request Forgery in ftp-srv
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- ftp-srv
- Severity
- High
- Weaknesses
- CWE-918
- Reviewed
- 2020-08-31
Affected packages
• npm ftp-srv: >= 1.0.0, < 2.19.6 → fixed in 2.19.6
• npm ftp-srv: >= 3.0.0, < 3.1.2 → fixed in 3.1.2
• npm ftp-srv: >= 4.0.0, < 4.3.4 → fixed in 4.3.4
Description
All versions of `ftp-srv` from v1.0.0 onward to v4.3.3 are vulnerable to Server-Side Request Forgery (SSRF). The package fails to prevent remote clients to access other resources in the network, for example when connecting to the server through telnet. This allows attackers to access any network resources available to the server, including private resources in the hosting environment.
Recommendation
Upgrade to patched versions
`^2.19.6, ^3.1.2, ^4.3.4`
Workarounds
Blacklisting the FTP Command PORT will prevent the server from exposing this behaviour through active connections until a fix is applied.
```
const ftp = new FtpSrv({
blacklist: ['PORT']
});
```
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness