GitHub Advisoryadvisory · Maven

GHSA-r4q3-7g4q-x89m Spring Framework server Web DoS Vulnerability

HIGH Published 2024-01-22 Modified 2025-06-20 Official page ↗
Aliases
CVE-2024-22233
Ecosystem
Maven
Packages
org.springframework:spring-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2024-01-23

Affected packages

• Maven org.springframework:spring-core: >= 6.1.2, < 6.1.3 → fixed in 6.1.3 • Maven org.springframework:spring-core: >= 6.0.15, < 6.0.16 → fixed in 6.0.16

Description

In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: • the application uses Spring MVC • Spring Security 6.1.6+ or 6.2.1+ is on the classpath Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.

Related

Alias · CVE (1)

  • CVE-2024-22233 In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References