GitHub Advisoryadvisory · PyPI

GHSA-r4v4-3jj7-jc29 OpenStack Octavia Amphora-Agent not requiring Client-Certificate

CRITICAL Published 2022-05-24 Modified 2024-05-02 Official page ↗
Aliases
CVE-2019-17134
Ecosystem
PyPI
Packages
octavia
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-287
Reviewed
2024-05-02

Affected packages

• PyPI octavia: >= 0.10.0, < 2.1.2 → fixed in 2.1.2 • PyPI octavia: >= 3.0.0, < 3.2.0 → fixed in 3.2.0 • PyPI octavia: >= 4.0.0, < 4.1.0 → fixed in 4.1.0

Description

Amphora Images in OpenStack Octavia >=0.10.0 =3.0.0 =4.0.0 <4.1.0 allows anyone with access to the management network to bypass client-certificate based authentication and retrieve information or issue configuration commands via simple HTTP requests to the Agent on port https/9443, because the `cmd/agent.py` gunicorn cert_reqs option is True but is supposed to be ssl.CERT_REQUIRED.

Related

Alias · CVE (1)

  • CVE-2019-17134 Amphora Images in OpenStack Octavia >=0.10.0 <2.1.2, >=3.0.0 <3.2.0, >=4.0.0 <4.1.0 allows anyone with access to the management network to… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References