GitHub Advisoryadvisory · PyPI
GHSA-r562-m862-63w3 APM Java Agent Local Privilege Escalation
HIGH
Official page ↗
- Aliases
- CVE-2021-37941
- Ecosystem
- PyPI
- Packages
- elastic-apm
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
- Reviewed
- 2024-04-22
Affected packages
• PyPI elastic-apm: >= 1.10.0, < 1.27.0 → fixed in 1.27.0
Description
A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious file to an application running with the APM Java agent. Using this vector, a malicious or compromised user account could use the agent to run commands at a higher level of permissions than they possess. This vulnerability affects users that have set up the agent via the attacher cli 3, the attach API 2, as well as users that have enabled the profiling_inferred_spans_enabled option
Related
Alias · CVE (1)
- CVE-2021-37941 A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious file to an… vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness