GitHub Advisoryadvisory · Packagist
GHSA-r5f2-4wf4-cv66 Cross-site Scripting in LimeSurvey
MEDIUM
Official page ↗
- Aliases
- CVE-2019-16173
- Ecosystem
- Packagist
- Packages
- limesurvey/limesurvey
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-02-14
Affected packages
• Packagist limesurvey/limesurvey: < 3.17.14 → fixed in 3.17.14
Description
LimeSurvey before v3.17.14 allows reflected XSS for escalating privileges from a low-privileged account to, for example, SuperAdmin. This occurs in application/core/Survey_Common_Action.php,
Related
Alias · CVE (1)
- CVE-2019-16173 LimeSurvey before v3.17.14 allows reflected XSS for escalating privileges from a low-privileged account to, for example, SuperAdmin. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-16173 advisory
- https://github.com/LimeSurvey/LimeSurvey/commit/f1c1ad2d24eb262363511fcca2e96ce737064006 web
- https://seclists.org/bugtraq/2019/Sep/27 web
- https://www.limesurvey.org/limesurvey-updates/2188-limesurvey-3-17-14-build-190902-released web
- http://packetstormsecurity.com/files/154479/LimeSurvey-3.17.13-Cross-Site-Scripting.html web
- http://seclists.org/fulldisclosure/2019/Sep/22 web