GitHub Advisoryadvisory · Packagist

GHSA-r5j5-q42h-fc93 Mautic is Vulnerable to SQL Injection through Contact Activity API Sorting

HIGH Published 2026-02-25 Modified 2026-02-25 Official page ↗
Aliases
CVE-2026-3105
Ecosystem
Packagist
Packages
mautic/core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
Weaknesses
CWE-89
Reviewed
2026-02-25

Affected packages

• Packagist mautic/core: >= 2.10.0, < 5.2.10 → fixed in 5.2.10 • Packagist mautic/core: >= 6.0.0-alpha, < 6.0.8 → fixed in 6.0.8 • Packagist mautic/core: >= 7.0.0-alpha, < 7.0.1 → fixed in 7.0.1

Description

Summary This advisory addresses a SQL Injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API. Mitigation Please update to 5.2.10, 6.0.8, 7.0.1 or later. Workarounds None. References If there are any questions or comments about this advisory: Email Mautic at [email protected]

Related

Alias · CVE (1)

  • CVE-2026-3105 SummaryThis advisory addresses a SQL injection vulnerability in the API endpoint used for retrieving contact activities. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References