GitHub Advisoryadvisory · npm

GHSA-r5wg-q8fc-p6w2 Highcharts Grid parses pagination language options as HTML

HIGH Published 2026-10-28 Modified 2026-10-28 Official page ↗
Aliases
CVE-2026-118254
Ecosystem
npm
Packages
@highcharts/grid-lite, @highcharts/grid-pro
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2026-10-28

Affected packages

• npm @highcharts/grid-lite: >= 2.0.0, < 3.2.0 → fixed in 3.2.0 • npm @highcharts/grid-pro: >= 2.0.0, < 3.2.0 → fixed in 3.2.0

Description

Impact The pagination language strings are written into the DOM as markup rather than as text. An attacker who controls those language options can supply elements carrying event handlers, and those handlers execute in the origin of the page hosting the Grid when the pagination controls render. Exploitation requires that untrusted data reach the Grid language configuration and that pagination be enabled on the Grid. Workarounds Run this once after loading the Grid, before creating any grid: ```javascript { const Pagination = Grid.Pagination; const escapeLang = (pagination) => { const lang = pagination.lang; if (!lang) { return; } for (const key of ['pageInfo', 'pageSizeLabel']) { if (typeof lang[key] === 'string') { lang[key] = lang[key].replace(/</g, '&lt;'); } } }; for (const name of ['updatePageInfo', 'renderPageSizeSelector']) { const original = Pagination.prototype[name]; Pagination.prototype[name] = function (...args) { escapeLang(this); return original.apply(this, args); }; } } ``` Obtaining the patched version The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example `npm install @highcharts/[email protected]`. If you load Highcharts Grid from a CDN, use a versioned URL, for example `https://cdn.jsdelivr.net/npm/@highcharts/[email protected]/grid-lite.js`. For more on each installation method, see the installation guide.

Related

Alias · CVE (1)

  • CVE-2026-118254 Highcharts JS is a JavaScript charting library based on SVG. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References