GitHub Advisoryadvisory · npm

GHSA-r657-33vp-gp22 parse-server auth adapter app ID validation can be circumvented

LOW Published 2022-09-21 Modified 2022-09-21 Official page ↗
Aliases
CVE-2022-39231
Ecosystem
npm
Packages
parse-server
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-287
Reviewed
2022-09-21

Affected packages

• npm parse-server: < 4.10.16 → fixed in 4.10.16 • npm parse-server: >= 5.0.0, < 5.2.7 → fixed in 5.2.7

Description

Impact Validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. This fixes a vulnerability that affects configurations which allow users to authenticate using the Parse Server authentication adapter for _Facebook_ or _Spotify_ and where the server-side authentication adapter configuration `appIds` is set as a string (e.g. `abc`) instead of an array of strings (e.g. `["abc"]`). The vulnerability makes it possible to authenticate requests which are coming from a _Facebook_ or _Spotify_ app with a different app ID than the one specified in the `appIds` configuration. Both adapters still validate the access token with the respective authentication provider. An app ID is automatically assigned by the authentication provider. For this vulnerability to be exploited, an attacker would have to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. The documentation did not explicitly specify that the parameter `appIds` must be set as an array of strings and setting a string also worked. Therefore, there is a possibility that there are deployments where `appIds` is set as a string, making them vulnerable. Patches The fix makes Parse Server check the type of the value set for `appIds` and throws an error if the value is not an array. Workarounds No known workarounds. References • GitHub advisory GHSA-r657-33vp-gp22

Related

Alias · CVE (1)

  • CVE-2022-39231 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References