GitHub Advisoryadvisory · Go

GHSA-r6cc-7wj7-gfx2 Kubernetes csi-proxy vulnerable to privilege escalation due to improper input validation

HIGH Published 2023-11-03 Modified 2025-07-09 Official page ↗
Aliases
CVE-2023-3893
Ecosystem
Go
Packages
github.com/kubernetes-csi/csi-proxy/v2, github.com/kubernetes-csi/csi-proxy
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2023-11-03

Affected packages

• Go github.com/kubernetes-csi/csi-proxy/v2: >= 2.0.0-alpha.0, < 2.0.0-alpha.1 → fixed in 2.0.0-alpha.1 • Go github.com/kubernetes-csi/csi-proxy: >= 0.1.0-rc1, < 1.1.3 → fixed in 1.1.3 • Go github.com/kubernetes-csi/csi-proxy: < 0.0.0-20230821192013-2523e6674ded → fixed in 0.0.0-20230821192013-2523e6674ded • Go github.com/kubernetes-csi/csi-proxy: >= 1.1.3-0, < 1.1.3-0.20230821192013-2523e6674ded → fixed in 1.1.3-0.20230821192013-2523e6674ded

Description

Kubernetes is vulnerable to privilege escalation when a user that can create pods on Windows nodes running kubernetes-csi-proxy may be able to escalate to admin privileges on those nodes. Kubernetes clusters are only affected if they include Windows nodes running kubernetes-csi-proxy.

Related

Alias · CVE (1)

  • CVE-2023-3893 A security issue was discovered in Kubernetes where a user that can create pods on Windows nodes running kubernetes-csi-proxy may be able… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References