GitHub Advisoryadvisory · PyPI
GHSA-r6h7-5pq2-j77h Insufficiently random values in Ansible
MEDIUM
Official page ↗
- Aliases
- CVE-2020-10729
- Ecosystem
- PyPI
- Packages
- ansible
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-330
- Reviewed
- 2021-06-01
Affected packages
• PyPI ansible: < 2.9.6 → fixed in 2.9.6
Description
A flaw was found in the use of insufficiently random values in Ansible. Two random password lookups of the same length generate the equal value as the template caching action for the same file since no re-evaluation happens. The highest threat from this vulnerability would be that all passwords are exposed at once for the file. This flaw affects Ansible Engine versions before 2.9.6.
Related
Alias · CVE (1)
- CVE-2020-10729 A flaw was found in the use of insufficiently random values in Ansible. vulnerability
Weakness · CWE (1)
- CWE-330 Use of Insufficiently Random Values weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-10729 advisory
- https://github.com/ansible/ansible/issues/34144 web
- https://github.com/ansible/ansible/pull/67429 web
- https://github.com/ansible/ansible/commit/c520d70bf4748c8ee6718a7d0d0254051ba1c2e9 web
- https://bugzilla.redhat.com/show_bug.cgi?id=1831089 web
- https://github.com/advisories/GHSA-r6h7-5pq2-j77h advisory
- https://github.com/ansible/ansible package
- https://github.com/ansible/ansible/blob/v2.9.6/changelogs/CHANGELOG-v2.9.rst web
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-105.yaml web
- https://www.debian.org/security/2021/dsa-4950 web