GitHub Advisoryadvisory · Maven
GHSA-r6j3-px5g-cq3x Apache Tomcat Improper Input Validation vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-45648
- Ecosystem
- Maven
- Packages
- org.apache.tomcat:tomcat, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat-coyote
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2023-10-10
Affected packages
• Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.0-M12 → fixed in 11.0.0-M12
• Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.14 → fixed in 10.1.14
• Maven org.apache.tomcat:tomcat: >= 9.0.0-M1, < 9.0.81 → fixed in 9.0.81
• Maven org.apache.tomcat:tomcat: >= 8.5.0, < 8.5.94 → fixed in 8.5.94
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.0-M12 → fixed in 11.0.0-M12
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.14 → fixed in 10.1.14
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0-M1, < 9.0.81 → fixed in 9.0.81
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, < 8.5.94 → fixed in 8.5.94
• Maven org.apache.tomcat:tomcat-coyote: >= 11.0.0-M1, < 11.0.0-M12 → fixed in 11.0.0-M12
• Maven org.apache.tomcat:tomcat-coyote: >= 10.1.0-M1, < 10.1.14 → fixed in 10.1.14
• Maven org.apache.tomcat:tomcat-coyote: >= 9.0.0-M1, < 9.0.81 → fixed in 9.0.81
• Maven org.apache.tomcat:tomcat-coyote: >= 8.5.0, < 8.5.94 → fixed in 8.5.94
Description
Improper Input Validation vulnerability in Apache Tomcat.
Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single
request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.
Related
Alias · CVE (1)
- CVE-2023-45648 Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-45648 advisory
- https://github.com/apache/tomcat/commit/59583245639d8c42ae0009f4a4a70464d3ea70a0 web
- https://github.com/apache/tomcat/commit/8ecff306507be8e4fd3adee1ae5de1ea6661a8f4 web
- https://github.com/apache/tomcat/commit/c83fe47725f7ae9ae213568d9039171124fb7ec6 web
- https://github.com/apache/tomcat/commit/eb5c094e5560764cda436362254997511a3ca1f6 web
- https://github.com/apache/tomcat package
- https://lists.apache.org/thread/2pv8yz1pyp088tsxfb7ogltk9msk0jdp web
- https://lists.debian.org/debian-lts-announce/2023/10/msg00020.html web
- https://security.netapp.com/advisory/ntap-20231103-0007 web
- https://www.debian.org/security/2023/dsa-5521 web
- https://www.debian.org/security/2023/dsa-5522 web
- http://www.openwall.com/lists/oss-security/2023/10/10/10 web