GitHub Advisoryadvisory · Packagist
GHSA-r6qq-qc9m-98w2 EC-CUBE Cross-site scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-20751
- Ecosystem
- Packagist
- Packages
- ec-cube/ec-cube
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-25
Affected packages
• Packagist ec-cube/ec-cube: >= 4.0.0, < 4.0.6 → fixed in 4.0.6
Description
Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.
Related
Alias · CVE (1)
- CVE-2021-20751 Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness