GitHub Advisoryadvisory · Packagist

GHSA-r7cm-g469-wm4g Magento Open Source Improper Access Control vulnerability

MEDIUM Published 2024-06-13 Modified 2024-08-07 Official page ↗
Aliases
CVE-2024-34107
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-284
Reviewed
2024-08-07

Affected packages

• Packagist magento/community-edition: 2.4.7 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p6 → fixed in 2.4.6-p6 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p8 → fixed in 2.4.5-p8 • Packagist magento/community-edition: < 2.4.4-p9 → fixed in 2.4.4-p9

Description

Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2024-34107 Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by an Improper Access Control vulnerability that could… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References