GitHub Advisoryadvisory · Packagist

GHSA-r7q4-cw9r-vhp4 Concrete CMS Stored XSS in the Custom Class page editing

LOW Published 2024-04-03 Modified 2024-04-03 Official page ↗
Aliases
CVE-2024-3179
Ecosystem
Packagist
Packages
concrete5/concrete5
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L
Weaknesses
CWE-20, CWE-79
Reviewed
2024-04-03

Affected packages

• Packagist concrete5/concrete5: >= 9.0.0RC1, < 9.2.8 → fixed in 9.2.8 • Packagist concrete5/concrete5: < 8.5.16 → fixed in 8.5.16

Description

Concrete CMS version 9 before 9.2.8 and previous versions before 8.5.16 are vulnerable to Stored XSS in the Custom Class page editing. Prior to the fix, a rogue administrator could insert malicious code in the custom class field due to insufficient validation of administrator provided data. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Thanks Alexey Solovyev for reporting.

Related

Alias · CVE (1)

  • CVE-2024-3179 Concrete CMS version 9 before 9.2.8 and previous versions before 8.5.16 are vulnerable to Stored XSS in the Custom Class page editing. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References