GitHub Advisoryadvisory · RubyGems
GHSA-r8fh-hq2p-7qhq Active Record contains SQL Injection via improper range quoting
HIGH
Official page ↗
- Aliases
- CVE-2014-3483
- Ecosystem
- RubyGems
- Packages
- activerecord
- Severity
- High
- Weaknesses
- CWE-89
- Reviewed
- 2020-06-16
Affected packages
• RubyGems activerecord: >= 4.0.0, < 4.0.7 → fixed in 4.0.7
• RubyGems activerecord: >= 4.1.0, < 4.1.3 → fixed in 4.1.3
Description
SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.
Related
Alias · CVE (1)
- CVE-2014-3483 SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for… vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3483 advisory
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2014-3483.yml web
- https://groups.google.com/forum/message/raw?msg=rubyonrails-security/wDxePLJGZdI/WP7EasCJTA4J web
- https://web.archive.org/web/20200228150648/http://www.securityfocus.com/bid/68341 web
- http://openwall.com/lists/oss-security/2014/07/02/5 web
- http://rhn.redhat.com/errata/RHSA-2014-0877.html web
- http://www.debian.org/security/2014/dsa-2982 web