GitHub Advisoryadvisory · npm, Packagist, NuGet, PyPI
GHSA-r8hm-w5f7-wj39 Cross-site scripting vulnerability in TinyMCE plugins
MEDIUM
Official page ↗
- Aliases
- CVE-2024-21910
- Ecosystem
- npm, Packagist, NuGet, PyPI
- Packages
- tinymce, tinymce/tinymce, TinyMCE, django-tinymce
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-64, CWE-79
- Reviewed
- 2021-11-01
Affected packages
• npm tinymce: < 5.10.0 → fixed in 5.10.0
• Packagist tinymce/tinymce: < 5.10.0 → fixed in 5.10.0
• NuGet TinyMCE: < 5.10.0 → fixed in 5.10.0
• PyPI django-tinymce: < 3.4.0 → fixed in 3.4.0
Description
Impact
A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the `image` and `link` plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower.
Patches
This vulnerability has been patched in TinyMCE 5.10.0 by improved sanitization logic when updating URLs in the relevant plugins.
Workarounds
To work around this vulnerability, either:
• Upgrade to TinyMCE 5.10.0 or higher
• Disable the `image` and `link` plugins
Acknowledgements
Tiny Technologies would like to thank Yakir6 for discovering this vulnerability.
References
https://www.tiny.cloud/docs/release-notes/release-notes510/#securityfixes
For more information
If you have any questions or comments about this advisory:
• Email us at [email protected]
• Open an issue in the TinyMCE repo
Related
Alias · CVE (1)
- CVE-2024-21910 TinyMCE versions before 5.10.0 are affected by a cross-site scripting vulnerability. vulnerability