GitHub Advisoryadvisory · Packagist

GHSA-r8v4-7vwj-983x SimpleSAMLphp SAML2 spoof SAML responses

CRITICAL Published 2022-05-14 Modified 2024-04-25 Official page ↗
Aliases
CVE-2016-9814
Ecosystem
Packagist
Packages
simplesamlphp/saml2
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Reviewed
2024-04-25

Affected packages

• Packagist simplesamlphp/saml2: >= 1.10, < 1.10.3 → fixed in 1.10.3 • Packagist simplesamlphp/saml2: < 1.8.1 → fixed in 1.8.1 • Packagist simplesamlphp/saml2: >= 1.9.0, < 1.9.1 → fixed in 1.9.1 • Packagist simplesamlphp/saml2: >= 2.0, < 2.3.3 → fixed in 2.3.3

Description

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Related

Alias · CVE (1)

  • CVE-2016-9814 The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x… vulnerability

References