GitHub Advisoryadvisory · Packagist
GHSA-r8w8-74ww-j4wh PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via JavaScript hyperlinks
MEDIUM
Official page ↗
- Aliases
- CVE-2024-45292
- Ecosystem
- Packagist
- Packages
- phpoffice/phpspreadsheet, phpoffice/phpexcel
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-10-07
Affected packages
• Packagist phpoffice/phpspreadsheet: >= 2.2.0, < 2.3.0 → fixed in 2.3.0
• Packagist phpoffice/phpspreadsheet: < 1.29.2 → fixed in 1.29.2
• Packagist phpoffice/phpspreadsheet: >= 2.0.0, < 2.1.1 → fixed in 2.1.1
• Packagist phpoffice/phpexcel: <= 1.8.2 (no fix yet)
Description
Summary
`\PhpOffice\PhpSpreadsheet\Writer\Html` does not sanitize "javascript:" URLs from hyperlink `href` attributes, resulting in a Cross-Site Scripting vulnerability.
PoC
Example target script:
```
load(__DIR__ . '/book.xlsx');
$writer = new \PhpOffice\PhpSpreadsheet\Writer\Html($spreadsheet);
print($writer->generateHTMLAll());
```
Save this file in the same directory:
book.xlsx
Open index.php in a web browser and click on both links. The first demonstrates the vulnerability in a regular hyperlink and the second in a HYPERLINK() formula.
Related
Alias · CVE (1)
- CVE-2024-45292 PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-r8w8-74ww-j4wh web
- https://nvd.nist.gov/vuln/detail/CVE-2024-45292 advisory
- https://github.com/PHPOffice/PhpSpreadsheet/commit/392dd08c5569b623060784e1333454d64df1f03d web
- https://github.com/PHPOffice/PhpSpreadsheet/commit/8b9b378ecdc603234a34aab3b293d2cdc8e9210e web
- https://github.com/PHPOffice/PhpSpreadsheet/commit/f0b70ed1086348904b27772b264e1605ba6c1d6d web
- https://github.com/PHPOffice/PhpSpreadsheet package