GitHub Advisoryadvisory · Maven
GHSA-r936-gwx5-v52f Spring Framework MVC Applications Path Traversal Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-41242
- Ecosystem
- Maven
- Packages
- org.springframework:spring-webmvc
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2025-08-18
Affected packages
• Maven org.springframework:spring-webmvc: >= 6.2.0, < 6.2.10 → fixed in 6.2.10
• Maven org.springframework:spring-webmvc: >= 6.1.0, <= 6.1.21 (no fix yet)
• Maven org.springframework:spring-webmvc: >= 6.0.0, <= 6.0.29 (no fix yet)
• Maven org.springframework:spring-webmvc: >= 5.3.0, <= 5.3.43 (no fix yet)
Description
Spring Framework MVC applications can be vulnerable to a “Path Traversal Vulnerability” when deployed on a non-compliant Servlet container.
An application can be vulnerable when all the following are true:
• the application is deployed as a WAR or with an embedded Servlet container
• the Servlet container does not reject suspicious sequences https://jakarta.ee/specifications/servlet/6.1/jakarta-servlet-spec-6.1.html#uri-path-canonicalization
• the application serves static resources https://docs.spring.io/spring-framework/reference/web/webmvc/mvc-config/static-resources.html#page-title with Spring resource handling
We have verified that applications deployed on Apache Tomcat or Eclipse Jetty are not vulnerable, as long as default security features are not disabled in the configuration. Because we cannot check exploits against all Servlet containers and configuration variants, we strongly recommend upgrading your application.
Related
Alias · CVE (1)
- CVE-2025-41242 Spring Framework MVC applications can be vulnerable to a “Path Traversal Vulnerability” when deployed on a non-compliant Servlet container. vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness