GitHub Advisoryadvisory · PyPI

GHSA-r9hx-vwmv-q579 pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS)

HIGH Published 2022-12-23 Modified 2025-11-04 Official page ↗
Aliases
CVE-2022-40897
Ecosystem
PyPI
Packages
setuptools
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-1333
Reviewed
2022-12-27

Affected packages

• PyPI setuptools: < 65.5.1 → fixed in 65.5.1

Description

Python Packaging Authority (PyPA)'s setuptools is a library designed to facilitate packaging Python projects. Setuptools version 65.5.0 and earlier could allow remote attackers to cause a denial of service by fetching malicious HTML from a PyPI package or custom PackageIndex page due to a vulnerable Regular Expression in `package_index`. This has been patched in version 65.5.1.

Related

Alias · CVE (1)

  • CVE-2022-40897 Python Packaging Authority (PyPA) setuptools before 65.5.1 allows remote attackers to cause a denial of service via HTML in a crafted… vulnerability

Weakness · CWE (1)

  • CWE-1333 Inefficient Regular Expression Complexity weakness

References