GitHub Advisoryadvisory · PyPI

GHSA-r9jw-mwhq-wp62 PyJWT vulnerable to key confusion attacks

HIGH Published 2022-05-13 Modified 2024-10-15 Official page ↗
Aliases
CVE-2017-11424
Ecosystem
PyPI
Packages
pyjwt
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Reviewed
2022-09-12

Affected packages

• PyPI pyjwt: < 1.5.1 → fixed in 1.5.1

Description

In PyJWT 1.5.0 and below the `invalid_strings` check in `HMACAlgorithm.prepare_key` does not account for all PEM encoded public keys. Specifically, the PKCS1 PEM encoded format would be allowed because it is prefaced with the string `-----BEGIN RSA PUBLIC KEY-----` which is not accounted for. This enables symmetric/asymmetric key confusion attacks against users using the PKCS1 PEM encoded public keys, which would allow an attacker to craft JWTs from scratch.

Related

Alias · CVE (1)

  • CVE-2017-11424 In PyJWT 1.5.0 and below the `invalid_strings` check in `HMACAlgorithm.prepare_key` does not account for all PEM encoded public keys. vulnerability

References