GitHub Advisoryadvisory · npm
GHSA-r9ph-3637-55px Backstage: Improper entity validation in deprecated Kubernetes services endpoint
MEDIUM
Official page ↗
- Aliases
- CVE-2026-106563
- Ecosystem
- npm
- Packages
- @backstage/plugin-kubernetes-backend
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-20, CWE-862
- Reviewed
- 2026-10-07
Affected packages
• npm @backstage/plugin-kubernetes-backend: < 0.21.8 → fixed in 0.21.8
Description
Impact
An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters.
Patches
Patched in `@backstage/plugin-kubernetes-backend` version 0.21.8.
Workarounds
• Disable the deprecated `/services/:serviceId` route by deploying a custom Kubernetes router that omits it.
• Restrict access to the `kubernetes.resources.read` permission to limit the set of users who can reach the endpoint.
Related
Alias · CVE (1)
- CVE-2026-106563 Backstage is an open framework for building developer portals. vulnerability
References
- https://github.com/backstage/backstage/security/advisories/GHSA-r9ph-3637-55px web
- https://nvd.nist.gov/vuln/detail/CVE-2026-106563 advisory
- https://github.com/backstage/backstage/commit/2d5d3e77d630455d6d48cfa8f31fd3c126fd6f29 web
- https://github.com/backstage/backstage package
- https://github.com/backstage/backstage/releases/tag/v1.54.1 web