GitHub Advisoryadvisory · Go
GHSA-r9px-m959-cxf4 go-git clients vulnerable to DoS via maliciously crafted Git server replies
HIGH
Official page ↗
- Aliases
- CVE-2025-21614
- Ecosystem
- Go
- Packages
- gopkg.in/src-d/go-git.v4, github.com/go-git/go-git/v5, github.com/go-git/go-git
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20, CWE-400, CWE-770
- Reviewed
- 2025-01-06
Affected packages
• Go gopkg.in/src-d/go-git.v4: >= 4.0.0, <= 4.13.1 (no fix yet)
• Go github.com/go-git/go-git/v5: < 5.13.0 → fixed in 5.13.0
• Go github.com/go-git/go-git: >= 4.0.0, <= 4.13.1 (no fix yet)
Description
Impact
A denial of service (DoS) vulnerability was discovered in go-git versions prior to `v5.13`. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in `go-git` clients.
This is a `go-git` implementation issue and does not affect the upstream `git` cli.
Patches
Users running versions of `go-git` from `v4` and above are recommended to upgrade to `v5.13` in order to mitigate this vulnerability.
Workarounds
In cases where a bump to the latest version of `go-git` is not possible, we recommend limiting its use to only trust-worthy Git servers.
Credit
Thanks to Ionut Lalu for responsibly disclosing this vulnerability to us.
Related
Alias · CVE (1)
- CVE-2025-21614 go-git is a highly extensible git implementation library written in pure Go. vulnerability