GitHub Advisoryadvisory · Maven
GHSA-r9q2-3r6x-qmgp Inadequate Encryption Strength in Jenkins
MEDIUM
Official page ↗
- Aliases
- CVE-2017-2598
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-326
- Reviewed
- 2022-07-01
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.32.2 → fixed in 2.32.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.34, < 2.44 → fixed in 2.44
Description
Jenkins before versions 2.44 and 2.32.2 uses AES ECB block cipher mode without IV for encrypting secrets which makes Jenkins and the stored secrets vulnerable to unnecessary risks (SECURITY-304).
Related
Alias · CVE (1)
- CVE-2017-2598 Jenkins before versions 2.44, 2.32.2 uses AES ECB block cipher mode without IV for encrypting secrets which makes Jenkins and the stored… vulnerability
Weakness · CWE (1)
- CWE-326 Inadequate Encryption Strength weakness