GitHub Advisoryadvisory · Maven

GHSA-rc2r-w8jv-vggp Cloud Foundry vulnerable to Improper Certificate Validation

MEDIUM Published 2022-05-14 Modified 2024-02-28 Official page ↗
Aliases
CVE-2016-5016
Ecosystem
Maven
Packages
org.cloudfoundry.identity:cloudfoundry-identity-server
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-295
Reviewed
2024-02-28

Affected packages

• Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.0.0, < 3.3.0.3 → fixed in 3.3.0.3 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.4.0, < 3.4.2 → fixed in 3.4.2

Description

Pivotal Cloud Foundry 239 and earlier, UAA (aka User Account and Authentication Server) 3.4.1 and earlier, UAA release 12.2 and earlier, PCF (aka Pivotal Cloud Foundry) Elastic Runtime 1.6.x before 1.6.35, and PCF Elastic Runtime 1.7.x before 1.7.13 does not validate if a certificate is expired.

Related

Alias · CVE (1)

  • CVE-2016-5016 Pivotal Cloud Foundry 239 and earlier, UAA (aka User Account and Authentication Server) 3.4.1 and earlier, UAA release 12.2 and earlier,… vulnerability

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References