GitHub Advisoryadvisory · Maven

GHSA-rc7h-x6cq-988q Improper Input Validation in JGroups

CRITICAL Published 2022-05-13 Modified 2023-06-01 Official page ↗
Aliases
CVE-2016-2141
Ecosystem
Maven
Packages
org.jgroups:jgroups
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2022-07-06

Affected packages

• Maven org.jgroups:jgroups: >= 3.3.0.Alpha1, < 3.6.10.Final → fixed in 3.6.10.Final • Maven org.jgroups:jgroups: < 3.2.16.Final → fixed in 3.2.16.Final

Description

JGroups before 4.0 does not require the proper headers for the ENCRYPT and AUTH protocols from nodes joining the cluster, which allows remote attackers to bypass security restrictions and send and receive messages within the cluster via unspecified vectors. Fixes for this issue have been backported to versions 3.6.10.Final and 3.2.16.Final.

Related

Alias · CVE (1)

  • CVE-2016-2141 It was found that JGroups did not require necessary headers for encrypt and auth protocols from new nodes joining the cluster. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References