GitHub Advisoryadvisory · Packagist
GHSA-rc8x-jrrc-frfv Laravel does not properly constrain the host portion of a password-reset URL
MEDIUM
Official page ↗
- Aliases
- CVE-2017-9303
- Ecosystem
- Packagist
- Packages
- laravel/laravel, illuminate/auth, laravel/framework
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2024-04-25
Affected packages
• Packagist laravel/laravel: >= 5.4.0, < 5.4.22 → fixed in 5.4.22
• Packagist illuminate/auth: >= 5.3.0, <= 5.3.31 (no fix yet)
• Packagist illuminate/auth: >= 5.4.0, < 5.4.22 → fixed in 5.4.22
• Packagist laravel/framework: >= 5.3.0, <= 5.3.31 (no fix yet)
• Packagist laravel/framework: >= 5.4.0, < 5.4.22 → fixed in 5.4.22
Description
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
Related
Alias · CVE (1)
- CVE-2017-9303 Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-9303 advisory
- https://github.com/laravel/framework/commit/cef10551820530632a86fa6f1306fee95c5cac43 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/illuminate/auth/CVE-2017-9303.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/laravel/framework/CVE-2017-9303.yaml web
- https://laravel-news.com/laravel-5-4-22-is-now-released-and-includes-a-security-fix web
- https://laravel.com/docs/5.4/releases#laravel-5.4.22 web
- https://web.archive.org/web/20171021180417/http://www.securityfocus.com/bid/98776 web
- http://www.securityfocus.com/bid/98776 web