GitHub Advisoryadvisory · npm, PyPI
GHSA-rch3-82jr-f9w9 Jupyter Notebook Vulnerable to Authentication Token Theft via CommandLinker XSS
HIGH
Official page ↗
- Aliases
- CVE-2026-40171
- Ecosystem
- npm, PyPI
- Packages
- @jupyter-notebook/help-extension, notebook, jupyterlab, @jupyterlab/help-extension
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Weaknesses
- CWE-601, CWE-79
- Reviewed
- 2026-04-30
Affected packages
• npm @jupyter-notebook/help-extension: >= 7.0.0, < 7.5.6 → fixed in 7.5.6
• PyPI notebook: >= 7.0.0, < 7.5.6 → fixed in 7.5.6
• PyPI jupyterlab: < 4.5.7 → fixed in 4.5.7
• npm @jupyterlab/help-extension: < 4.5.7 → fixed in 4.5.7
Description
Impact
A stored Cross-Site Scripting (XSS) vulnerability in Jupyter Notebook allows attackers to steal authentication tokens from users who open malicious notebook files and interact with elements that the attacker can make look indistinguishable from legitimate controls (single click interaction).
The vulnerability enables complete account takeover through the Jupyter REST API, allowing the attacker to:
1. Read all files
2. Modify/create files
3. Access running kernels and execute arbitrary code
4. Create terminals for shell access
Patches
Jupyter Notebook 7.5.6 and JupyterLab 4.5.7 include patches for this vulnerability.
Workarounds
The help extension can be disabled via CLI:
```
jupyter labextension disable @jupyter-notebook/help-extension
jupyter labextension disable @jupyterlab/help-extension
```
Hardening
The patched versions include a toggle to disable the command linker functionality altogether, for example via `overrides.json`:
```json
{
"@jupyterlab/apputils-extension:sanitizer": {
"allowCommandLinker": false
}
}
```
Resources
• https://jupyterlab.readthedocs.io/en/latest/user/commands.html#commands-in-markdown-output-and-files
Acknowledgments
Reported by Daniel Teixeira - NVIDIA AI Red Team
Related
Alias · CVE (1)
- CVE-2026-40171 In Jupyter Notebook versions 7.0.0 through 7.5.5, JupyterLab versions 4.5.6 and earlier, and the corresponding… vulnerability