GitHub Advisoryadvisory · Maven
GHSA-rcjc-c4pj-xxrp Apache Derby: LDAP injection vulnerability in authenticator
CRITICAL
Official page ↗
- Aliases
- CVE-2022-46337
- Ecosystem
- Maven
- Packages
- org.apache.derby:derby
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-94
- Reviewed
- 2023-11-20
Affected packages
• Maven org.apache.derby:derby: >= 10.1.1.0, <= 10.1.3.1 (no fix yet)
• Maven org.apache.derby:derby: >= 10.2.1.6, <= 10.2.2.0 (no fix yet)
• Maven org.apache.derby:derby: >= 10.3.1.4, <= 10.3.3.0 (no fix yet)
• Maven org.apache.derby:derby: >= 10.4.1.3, <= 10.4.2.0 (no fix yet)
• Maven org.apache.derby:derby: >= 10.5.1.1, <= 10.5.3.0 (no fix yet)
• Maven org.apache.derby:derby: >= 10.6.1.0, <= 10.6.2.1 (no fix yet)
• Maven org.apache.derby:derby: 10.7.1.1 (no fix yet)
• Maven org.apache.derby:derby: >= 10.8.1.2, <= 10.8.3.0 (no fix yet)
• Maven org.apache.derby:derby: 10.9.1.0 (no fix yet)
• Maven org.apache.derby:derby: >= 10.10.1.1, <= 10.10.2.0 (no fix yet)
• Maven org.apache.derby:derby: 10.11.1.1 (no fix yet)
• Maven org.apache.derby:derby: 10.12.1.1 (no fix yet)
• Maven org.apache.derby:derby: 10.13.1.1 (no fix yet)
• Maven org.apache.derby:derby: >= 10.14.2.0, < 10.14.2.1 → fixed in 10.14.2.1
• Maven org.apache.derby:derby: >= 10.16.1.1, < 10.16.1.2 → fixed in 10.16.1.2
• Maven org.apache.derby:derby: >= 10.15.1.3, < 10.15.2.1 → fixed in 10.15.2.1
Description
A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures.
Mitigation:
Users should upgrade to Java 21 and Derby 10.17.1.0.
Alternatively, users who wish to remain on older Java versions should build their own Derby distribution from one of the release families to which the fix was backported: 10.16, 10.15, and 10.14. Those are the releases which correspond, respectively, with Java LTS versions 17, 11, and 8.
Related
Alias · CVE (1)
- CVE-2022-46337 A cleverly devised username might bypass LDAP authentication checks. vulnerability