GitHub Advisoryadvisory · Maven
GHSA-rcqj-3fmp-5cqx Apache Pulsar Kafka Connector Logs Sensitive Information in Application Logs
MEDIUM
Official page ↗
- Aliases
- CVE-2025-30677
- Ecosystem
- Maven
- Packages
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor, org.apache.pulsar:pulsar-io-kafka
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-532
- Reviewed
- 2025-04-10
Affected packages
• Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor: < 3.0.11 → fixed in 3.0.11
• Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor: >= 3.3.0, < 3.3.6 → fixed in 3.3.6
• Maven org.apache.pulsar:pulsar-io-kafka-connect-adaptor: >= 4.0.0, < 4.0.4 → fixed in 4.0.4
• Maven org.apache.pulsar:pulsar-io-kafka: < 3.0.11 → fixed in 3.0.11
• Maven org.apache.pulsar:pulsar-io-kafka: >= 3.3.0, < 3.3.6 → fixed in 3.3.6
• Maven org.apache.pulsar:pulsar-io-kafka: >= 4.0.0, < 4.0.4 → fixed in 4.0.4
Description
Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs.
This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue.
This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4.
3.0.x version users should upgrade to at least 3.0.11.
3.3.x version users should upgrade to at least 3.3.6.
4.0.x version users should upgrade to at least 4.0.4.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Related
Alias · CVE (1)
- CVE-2025-30677 Apache Pulsar contains multiple connectors for integrating with Apache Kafka. vulnerability
Weakness · CWE (1)
- CWE-532 Insertion of Sensitive Information into Log File weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-30677 advisory
- https://github.com/apache/pulsar/pull/24128 web
- https://github.com/apache/pulsar package
- https://lists.apache.org/thread/zv5fwwrh374r1p5cmksxcd40ssxxko3d web
- https://pulsar.apache.org/security web
- http://www.openwall.com/lists/oss-security/2025/04/09/2 web