GitHub Advisoryadvisory · RubyGems

GHSA-rcx6-7jp6-pqf2 ember-source Cross-site Scripting vulnerability

MEDIUM Published 2022-05-14 Modified 2023-01-27 Official page ↗
Aliases
CVE-2014-0014
Ecosystem
RubyGems
Packages
ember-source
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-01-27

Affected packages

• RubyGems ember-source: >= 1.0.0.pre4.0, < 1.0.1 → fixed in 1.0.1 • RubyGems ember-source: >= 1.1.0, < 1.1.3 → fixed in 1.1.3 • RubyGems ember-source: >= 1.2.0.beta.1, < 1.2.1 → fixed in 1.2.1 • RubyGems ember-source: >= 1.3.0.beta.1, < 1.3.1 → fixed in 1.3.1 • RubyGems ember-source: >= 1.4.0-beta.1, < 1.4.0-beta.2 → fixed in 1.4.0-beta.2

Description

Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application using the `{{group}}` Helper and a crafted payload.

Related

Alias · CVE (1)

  • CVE-2014-0014 Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References