GitHub Advisoryadvisory · Packagist

GHSA-rg6w-c352-p8pg Concrete CMS vulnerable to Reflected Cross-site Scripting

MEDIUM Published 2022-11-15 Modified 2025-04-30 Official page ↗
Aliases
CVE-2022-43692
Ecosystem
Packagist
Packages
concrete5/concrete5
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-11-22

Affected packages

• Packagist concrete5/concrete5: < 8.5.10 → fixed in 8.5.10 • Packagist concrete5/concrete5: >= 9.0.0, < 9.1.3 → fixed in 9.1.3

Description

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Reflected XSS - user can cause an administrator to trigger reflected XSS with a url if the targeted administrator is using an old browser that lacks XSS protection. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Related

Alias · CVE (1)

  • CVE-2022-43692 Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Reflected XSS - user can cause an administrator… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References