GitHub Advisoryadvisory · PyPI
GHSA-rg9h-vx28-xxp5 llama-index has Insecure Temporary File
HIGH
Official page ↗
- Aliases
- CVE-2025-7707
- Ecosystem
- PyPI
- Packages
- llama-index
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- Weaknesses
- CWE-377
- Reviewed
- 2025-10-13
Affected packages
• PyPI llama-index: < 0.13.0 → fixed in 0.13.0
Description
The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2025-7707 The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable… vulnerability