GitHub Advisoryadvisory · Packagist

GHSA-rgcg-28xm-8mmw Cross-Site Scripting in Backend Grid View

MEDIUM Published 2021-07-22 Modified 2021-07-22 Official page ↗
Aliases
CVE-2021-32669
Ecosystem
Packagist
Packages
typo3/cms-core, typo3/cms
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2021-07-20

Affected packages

• Packagist typo3/cms-core: >= 8.0.0, < 8.7.41 → fixed in 8.7.41 • Packagist typo3/cms-core: >= 9.0.0, < 9.5.28 → fixed in 9.5.28 • Packagist typo3/cms-core: >= 10.0.0, < 10.4.18 → fixed in 10.4.18 • Packagist typo3/cms-core: >= 11.0.0, < 11.3.1 → fixed in 11.3.1 • Packagist typo3/cms: >= 10.0.0, < 10.4.18 → fixed in 10.4.18 • Packagist typo3/cms: >= 11.0.0, < 11.3.1 → fixed in 11.3.1 • Packagist typo3/cms: >= 9.0.0, < 9.5.28 → fixed in 9.5.28

Description

Problem Failing to properly encode settings for _backend layouts_, the corresponding grid view is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. Solution Update to TYPO3 versions 8.7.41 ELTS, 9.5.28, 10.4.18, 11.3.1 that fix the problem described. Credits Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.

Related

Alias · CVE (1)

  • CVE-2021-32669 TYPO3 is an open source PHP based web content management system. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References